A-A+
BGP配置实验之路由反射器
1、路由反射器解析
路由反射器工作原理:
RR从EBGP收到的路由,会反射给客户端和非客户端
RR从客户端收到的路由,会反射给客户端、EBGP邻居和非客户端
RR从非客户端收到的路由,只会反射给客户端和EBGP邻居,不会反射给非客户端
2、实验拓扑
3、基础配置
R1配置
- interface Loopback0
- ip address 1.1.1.1 255.255.255.0
- interface Serial0/0
- ip address 12.1.1.1 255.255.255.0
- router bgp 1
- no synchronization
- bgp router-id 1.1.1.1
- network 1.1.1.0 mask 255.255.255.0
- neighbor 12.1.1.2 remote-as 2
- no auto-summary
R2配置
- interface Loopback0
- ip address 2.2.2.2 255.255.255.0
- interface Serial0/0
- ip address 12.1.1.2 255.255.255.0
- interface Serial0/1
- ip address 23.1.1.2 255.255.255.0
- router ospf 110
- router-id 2.2.2.2
- network 2.2.2.0 0.0.0.255 area 0
- network 23.1.1.0 0.0.0.255 area 0
- router bgp 2
- no synchronization
- bgp router-id 2.2.2.2
- neighbor 3.3.3.3 remote-as 2
- neighbor 3.3.3.3 update-source Loopback0
- neighbor 3.3.3.3 next-hop-self
- neighbor 12.1.1.1 remote-as 1
- no auto-summary
R3配置
- interface Loopback0
- ip address 3.3.3.3 255.255.255.0
- interface Serial0/0
- ip address 34.1.1.3 255.255.255.0
- interface Serial0/1
- ip address 23.1.1.3 255.255.255.0
- router ospf 110
- router-id 3.3.3.3
- network 3.3.3.0 0.0.0.255 area 0
- network 23.1.1.0 0.0.0.255 area 0
- network 34.1.1.0 0.0.0.255 area 0
- router bgp 2
- no synchronization
- bgp router-id 3.3.3.3
- neighbor 2.2.2.2 remote-as 2
- neighbor 2.2.2.2 update-source Loopback0
- neighbor 4.4.4.4 remote-as 2
- neighbor 4.4.4.4 update-source Loopback0
- no auto-summary
R4配置 http://www.xiaoxiongboke.com/
- interface Loopback0
- ip address 4.4.4.4 255.255.255.0
- interface Serial0/0
- ip address 34.1.1.4 255.255.255.0
- router ospf 110
- router-id 4.4.4.4
- network 4.4.4.0 0.0.0.255 area 0
- network 34.1.1.0 0.0.0.255 area 0
- router bgp 2
- no synchronization
- bgp router-id 4.4.4.4
- neighbor 3.3.3.3 remote-as 2
- neighbor 3.3.3.3 update-source Loopback0
- no auto-summary
4、水平分割导致的问题
5、配置路由反射器解决水平分割
R3配置
router bgp 2
neighbor 2.2.2.2 route-reflector-client
neighbor 4.4.4.4 route-reflector-client